Ostatnio Na Forum
Polityka prywatności

Portal openrouter.info stosuje pliki cookies ("ciasteczka") pozwalające na dostosowanie zawartości portalu do indywidualnych potrzeb. Korzystanie z portalu bez zmiany ustawień dotyczących ciasteczek oznacza akceptację umieszczenia ich na urządzenia użytkownika. Zmianę ustawień pliku ciasteczek można wykonać zmieniając opcję w ustawieniach przeglądarki internetowej. Więcej informacji można znaleźć w Polityce prywatności.

OpenWrt 21.02.0

Mimo paru problemów zdecydowano się opublikować ostateczną wersję OpenWrt oznaczoną jako 21.02.0. Zawiera ona szereg zmian w stosunku do opublikowanej dwa lata temu wersji 19.07, łącznie ze zmienionym sposobem definiowania brigde, nową linią kernela, wsparciem dla nowych architektur ale także porzuceniem urządzeń które mają mało pamięci flash czy RAM lub tych które nie zostały przepisane na DTS.

Informacja o wydaniu poniżej (EN)

Cytuj:
The OpenWrt community is proud to announce the first stable release of the OpenWrt 21.02 stable version series. It incorporates over 5800 commits since branching the previous OpenWrt 19.07 release and has been under development for about one and a half year.


Highlights in OpenWrt 21.02.0

- ---
WPA3 support included by default

WPA3 was already supported in 19.07 but it was not provided by the default set of packages in OpenWrt images.

With 21.02, all packages necessary to provide WPA3 are installed by default in OpenWrt images. WPA3 is supported by most Wifi drivers in OpenWrt.

- ---
TLS and HTTPS support included by default

TLS support is now provided by default in OpenWrt images including the trusted CA certificates from Mozilla. It means that wget and opkg now support fetching resources over HTTPS out-of-the-box. The opkg download server is accessed through HTTPS by default. OpenWrt switched from mbedTLS to wolfSSL as the default SSL library. mbedTLS and OpenSSL are still available and can be installed manually.

In addition, LuCI is now available over HTTPS in addition to HTTP. There is no automatic redirection to HTTPS on a fresh OpenWrt 21.02 installation; however, redirection will be enabled after upgrading from OpenWrt 19.07 to OpenWrt 21.02.

It is always possible to activate or deactivate the redirection to HTTPS like this:

uci set uhttpd.main.redirect_https=1   # 1 to enable redirect,
                0 to disable redirect
uci commit uhttpd
service uhttpd reload

- ---
Initial DSA support

DSA stands for Distributed Switch Architecture and is the Linux standard to deal with configurable Ethernet switches.

OpenWrt 21.02 comes with initial support for DSA, which replaces the swconfig system that OpenWrt was using up until now. Not all targets have been ported: some devices still use swconfig while some devices already switched to DSA.

This is a significant change to how switch ports and VLANs are managed. As such, sysupgrade will not be able to convert existing swconfig configuration to DSA configuration (see ?Upgrading? below).

See the OpenWrt DSA Networking documentation for details. https://openwrt.org/docs/guide-user/network/dsa/start

The following targets are using a switch managed with DSA in OpenWrt 21.02:
* ath79 (only TP-Link TL-WR941ND)
* bcm4908
* gemini
* kirkwood
* mediatek (most boards)
* mvebu
* octeon
* ramips (mt7621 subtarget only)
* realtek

- ---
Increased minimum hardware requirements: 8 MB flash, 64 MB RAM

Due to new features being introduced and the general size increase of the Linux kernel, devices now need at least 8 MB of flash and 64 MB of RAM to run a default build of OpenWrt. More flash space is recommended for extensibility, see 8/64 warning: https://openwrt.org/supported_devices/864_warning

It is still possible to build custom OpenWrt images (e.g. using the ImageBuilder) that may fit devices with 4 MB of flash or 32 MB of RAM. However, the level of functionality will be reduced and there is no guarantee to stability. See OpenWrt on 4/32 devices for more details and guidance. https://openwrt.org/supported_devices/o ... 32_devices

- ---
New network configuration syntax and board.json change

There have been several changes to the network configuration syntax in /etc/config/network:

* in config interface, option ifname has been renamed to device (since t refers to a device section)
* in config device of type bridge, ifname has been renamed to ports
* for new installs, the generated configuration now creates separate sections for layer 2 (config device) and layer 3 (config interface) configuration

The old syntax is still supported to facilitate transition, and there is no automated migration when upgrading.

However, the LuCI web interface detects old-style configuration and will propose to migrate it to the new syntax. This is necessary to be able to edit network configuration through LuCI.

New UCI syntax

The new configuration style looks like this:

config device
   option name 'br-lan'
   option type 'bridge'
   option macaddr '00:01:02:XX:XX:XX'
   list ports 'lan1'
   list ports 'lan2'
   list ports 'lan3'
   list ports 'lan4'

config interface 'lan'
   option device 'br-lan'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config device
   option name 'eth1'
   option macaddr '00:01:02:YY:YY:YY'

config interface 'wan'
   option device 'eth1'
   option proto 'dhcp'

config interface 'wan6'
   option device 'eth1'
   option proto 'dhcpv6'

This example uses DSA with lanX interface names. A non-DSA device would use more classical ethX interface names.

Changes to board.json

In addition, network fields in board.json have also been renamed from ?ifname? to ?device?. In addition, DSA bridges now expose their list of ports in a ?ports? attribute.

If you rely on board.json, this change is not backwards compatible.

Example for a DSA bridge:

"network": {
         "lan": {
                 "ports": [
                         "lan1",
                         "lan2",
                         "lan3",
                         "lan4"
                 ],
                 "protocol": "static"
         },
         "wan": {
                 "device": "wan",
                 "protocol": "dhcp"
         }
}

Example for a classical swconfig switch configuration:

"network": {
         "lan": {
                 "device": "eth0",
                 "protocol": "static"
         },
         "wan": {
                 "device": "eth1",
                 "protocol": "dhcp"
         }
}


- ---
New hardware targets

A new realtek target has been added, which is often found in managed switches. As a result, it is now possible to run OpenWrt on devices with a significant number of Ethernet ports. See supported devices for realtek.

In addition, new bcm4908 and rockchip targets have been added.

Support for many new boards was added to the existing targets.

- ---
Dropped hardware targets

The ar71xx target was deprecated in OpenWrt 19.07 and has been gradually replaced by ath79, see ar71xx-ath79 migration. https://openwrt.org/docs/techref/targets/ar71xx-ath79

With OpenWrt 21.02, the ar71xx has now been removed and users must use ath79 instead. If you are still running with the ar71xx target, it is recommended to reinstall OpenWrt 21.02 from scratch. Users already on the ath79 target can use sysupgrade to upgrade to OpenWrt 21.02.

Other targets were also removed: cns3xxx, rb532 and samsung.

- ---
ASLR activated

Network exposed user space applications are linked as position-independent executable (PIE) to allow full Address Space Layout Randomization (ASLR) support. This makes it harder for attackers to exploit OpenWrt. See Hardening build options for more details. https://openwrt.org/docs/guide-develope ... ld_options

- ---
Kernel with container support

Multiple Linux kernel compile options, needed for Linux Containers (LXC) and procd-ujail are activated by default for most targets. This allows to use LXC and ujail with the normal release builds.

- ---
SELinux support

It is possible to compile OpenWrt with SELinux support. This is currently not activated by default.

- ---
Core components update

Core components have the following versions in 21.02.0:

* Updated toolchain:
* musl libc 1.1.24
* glibc 2.33
* gcc 8.4.0
* binutils 2.34
* Updated Linux kernel
* 5.4.143 for all targets
* Network:
* hostapd 2020-06-08, dnsmasq 2.85, dropbear 2020.81
* cfg80211/mac80211 from kernel 5.10.42
* wireguard backport from upstream Linux kernel
* System userland:
* busybox 1.33.1

In addition to the listed applications, many others were also updated.

- ---
Upgrading to 21.02.0

Sysupgrade can be used to upgrade a device from 19.07 to 21.02, and configuration will be preserved in most cases.

* Sysupgrade from 18.06 to 21.02 is not supported.

* There is no migration path for targets that switched from swconfig to DSA. In that case, sysupgrade will refuse to proceed with an appropriate error message:
Image version mismatch. image 1.1 device 1.0 Please wipe config during upgrade (force required) or reinstall. Config cannot be migrated from swconfig to DSA Image check failed

* The default root file system partition size changed for targets/devices relying on booting from mass storage (HDD, USB flash, SD card, etc.), so MBR will change and any additional partition will be deleted when sysupgrading.

- ---
Known issues

* Some IPv6 packets are dropped when software flow offloading is used: https://bugs.openwrt.org/index.php?do=d ... sk_id=3373
* As a workaround, do not activate software flow offloading, it is deactivate by default.


- ---

Full release notes and upgrade instructions are available at https://openwrt.org/releases/21.02/notes-21.02.0

In particular, make sure to read the regressions and known issues before upgrading: https://openwrt.org/releases/21.02/note ... own_issues

For a detailed list of all changes since 19.07 was branched off, refer to: https://openwrt.org/releases/21.02/changelog-21.02.0

To download the 21.02.0 images, navigate to: https://downloads.openwrt.org/releases/21.02.0/

- ---

To stay informed of new OpenWrt releases and security advisories, there are new channels available:

* a low-volume mailing list for important announcements: https://lists.openwrt.org/mailman/listi ... t-announce

* a dedicated "announcements" section in the forum: https://forum.openwrt.org/c/announcements/14

* other announcement channels (such as RSS feeds) might be added in the future, they will be listed at https://openwrt.org/contact


As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

  Więcej na forum…  

OpenWrt 19.07.8

Wydanie OpenWrt oznaczone 19.07.8 to głównie poprawki bezpieczeństwa niektórych pakietów oraz aktualizacje programów.

Informacja o wydaniu poniżej (EN):

Cytuj:
The OpenWrt community is proud to announce the eighth service release of OpenWrt 19.07. It fixes security issues, improves device support, and brings a few bug fixes.

The main changes from OpenWrt 19.07.7 are:

Security fixes
==============

* Fix FragAttacks (fragmentation and aggregation attacks) vulnerabilities in cfg80211, mac80211, ath10k and ath10k-ct
* We are not sure if some closed source firmware files are still affected by these problems.
* Security Advisory 2021-08-01-1 - XSS via missing input validation of host names displayed (CVE-2021-32019)
* Security Advisory 2021-08-01-2 - Stored XSS in hostname UCI variable (CVE-2021-33425)
* Security Advisory 2021-08-01-3 - luci-app-ddns: Multiple authenticated RCEs (CVE-2021-28961)
* Various security fixes in packages

Major bug fixes
===============

* Minor bugfixes to support GCC 11 as host compiler

Device support
==============

* TP-Link C7v5 allow flashing from vendor firmware bigger than v1.1
* FRIZZ!Box 7320 Activate power supply to USB ports.

Various fixes and improvements
==============================

* Only pack the signing keys for OpenWrt 19.07 and 21.02 and not the personal keys any more.

Core components
===============

* Update Linux kernel from 4.14.221 to 4.14.241
* Update mac80211 from 4.19.161-1 to 4.19.193-1
* Update ath10k-ct 4.19 driver from 2019-09-09 to 2021-06-03
* Update OpenVPN from 2.4.7 to 2.4.11
* Update openssl from 1.1.1i to 1.1.1k
* Update mbedtls from 2.16.9 to 2.16.10
* Update wolfssl from 4.6.0 to 4.7.0


Full release notes and upgrade instructions are available at https://openwrt.org/releases/19.07/notes-19.07.8

In particular, make sure to read the regressions and known issues before upgrading: https://openwrt.org/releases/19.07/note ... egressions

For a very detailed list of all changes since 19.07.7, refer to https://openwrt.org/releases/19.07/changelog-19.07.8

For latest information about the 19.07 series, refer to the wiki at: https://openwrt.org/releases/19.07/

To download a OpenWrt 19.07.8 firmware image for your device, head to the Table of Hardware: https://openwrt.org/toh/start

Or use the new firmware selector: https://firmware-selector.openwrt.org/

You can also navigate directly in the list of firmware images: https://downloads.openwrt.org/releases/19.07.8/targets/

As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

The OpenWrt Community

  Więcej na forum…  

OpenWrt 21.02.0-rc4

Kolejny wydanie OpenWrt oznaczone numerem 21.02.0-rc4 ujrzało światło dzienne. Jedną z głównych poprawek jest chyba naprawa trybu failsafe po migracji na nową składnię pliku konfiguracyjnego sieci.
Poniżej informacja o wydaniu (EN).

Cytuj:
The OpenWrt community is proud to announce the fourth release candidate of the upcoming OpenWrt 21.02 stable version series. It incorporates over 5800 commits since branching the previous OpenWrt 19.07 release and has been under development for about one and a half year.

Changes between OpenWrt 21.02.0-rc3 and 21.02.0-rc4

Software updates
* Linux kernel: updated to version 5.4.137 (from 5.4.124 in v21.02.0-rc3)
* mt76: Update to version 2021-06-06 (from 2021-05-15 in v21.02.0-rc3)
* wireguard: Update with recent Linux stable fixes
* exfat: Update to version 5.12.3 (from 5.10.1 in v21.02.0-rc3)

Misc changes
* failsafe: Fixes failsafe network configuration with swconfig and DSA: FS#3866
* odhcpd: fix invalid DHCPv6 ADVERTSIE with small configured leasetime
* ugps: parse $GPZDA and $GPGLL sentences, improve interoperability with kplex
* netifd: WDS with bridge-vlan fixed

Device support
* New devices MikroTik RouterBOARD 912UAG-2HPnD and Joy-IT JT-OR750i
* Device fixes for TP-Link CPE, MikroTik RouterBOARDs and AVM FRITZRepeater 1200

Known issues
* Some packets from IPv6 streams are getting dropped in software and hardware flow offloading: FS#3373


Full release notes and upgrade instructions are available at https://openwrt.org/releases/21.02/notes-21.02.0-rc4

In particular, make sure to read the regressions and known issues before upgrading: https://openwrt.org/releases/21.02/note ... own_issues

For a detailed list of all changes since 21.02.0-rc3, refer to https://openwrt.org/releases/21.02/chan ... 1.02.0-rc4

To download the 21.02.0-rc4 images, navigate to: https://downloads.openwrt.org/releases/21.02.0-rc4/

- ---

To stay informed of new OpenWrt releases and security advisories, there are new channels available:

* a low-volume mailing list for important announcements:
https://lists.openwrt.org/mailman/listi ... t-announce

* a dedicated "announcements" section in the forum:
https://forum.openwrt.org/c/announcements/14

* other announcement channels (such as RSS feeds) might be added in the
future, they will be listed at https://openwrt.org/contact


As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

The OpenWrt Community

  Więcej na forum…  

OpenWrt 21.02.0-rc3

Nowa wersja przyniosła przede wszystkim poprawki błędów zauważone po wydaniu -rc2, a także wsparcie dla kilku nowych urządzeń.

Informacja o wydaniu (EN):

Cytuj:
The OpenWrt community is proud to announce the third release candidate of the upcoming OpenWrt 21.02 stable version series. It incorporates over 5800 commits since branching the previous OpenWrt 19.07 release and has been under development for about one and a half year.

Changes between OpenWrt 21.02.0-rc2 and 21.02.0-rc3

LuCI
* LuCI network migration tool now migrates custom bridge MAC addresses.

Software updates
* Linux kernel updated to version 5.4.124 (from 5.4.119 in v21.02.0-rc2)
* mac80211 updated to version 5.10.42-1 (from 5.10.34-1 in v21.02.0-rc2)
* wireless-regdb updated to version 2021.04.21 (from 2020.11.20 in v21.02.0-rc2)

Misc changes
* opkg: Shows better error message when some dependencies are missing
* sdk, imagebuilder: json-c, libnl-tiny, libubox, ubus, uci and lua are marked nonshared and will be taken from release build and not package build.

Device support
* New devices: SERCOMM NA502, Linksys EA8100 v1, Amped Wireless ALLY, Linksys E5600, JCG Q20, cudy WR2100, TP-Link Archer C6U v1 (EU), TP-Link Archer A6 v3, ZyXEL NR7101, ZTE MF283+
* Device fixes for: Xiaomi Router 3 Pro, HILINK HLK-7628N, WD My Net Wi-Fi Range Extender, ALLNET ALL-WAP02860AC, Senao APs, TP-Link AD7200


Full release notes and upgrade instructions are available at https://openwrt.org/releases/21.02/notes-21.02.0-rc3

In particular, make sure to read the regressions and known issues before upgrading: https://openwrt.org/releases/21.02/note ... own_issues

For a detailed list of all changes since 21.02.0-rc2, refer to https://openwrt.org/releases/21.02/chan ... 1.02.0-rc3

To download the 21.02.0-rc2 images, navigate to: https://downloads.openwrt.org/releases/21.02.0-rc3/

- ---

To stay informed of new OpenWrt releases and security advisories, there are new channels available:

* a low-volume mailing list for important announcements: https://lists.openwrt.org/mailman/listi ... t-announce

* a dedicated "announcements" section in the forum: https://forum.openwrt.org/c/announcements/14

* other announcement channels (such as RSS feeds) might be added in the future, they will be listed at https://openwrt.org/contact


As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

The OpenWrt Community

  Więcej na forum…  

OpenWrt 21.02-rc2

Dostępna jest następna wersją kandydująca OpenWrt oznaczona jako 21.02-rc2. Dla niektórych niespodzianką może być zmiana składni pliku konfiguracyjnego sieci, ale deweloperzy zdecydowali się przenieść to już teraz z wersji rozwojowej OpenWrt, dołączając także odpowiednie zmiany w LuCI.
Poniżej informacja o wydaniu (EN):

Cytuj:
The OpenWrt community is proud to announce the second release candidate of the upcoming OpenWrt 21.02 stable version series. It incorporates over 5800 commits since branching the previous OpenWrt 19.07 release and has been under development for about one and a half year.


Changes between OpenWrt 21.02.0-rc1 and 21.02.0-rc2


New network configuration syntax

There have been several changes to the network configuration syntax in /etc/config/network:

* in config interface, option ifname has been renamed to device (since it refers to a device section)
* in config device of type bridge, ifname has been renamed to ports
* for new installs, the generated configuration now creates separate sections for layer 2 (config device) and layer 3 (config interface) configuration

The old syntax is still supported to facilitate transition, and there is no automated migration when upgrading.

However, the LuCI web interface detects old-style configuration and will propose to migrate it to the new syntax. This is necessary to be able to edit network configuration through LuCI.

The new configuration style looks like this:
--------------------------------------------------------------------------
config device
option name 'br-lan'
option type 'bridge'
option macaddr '00:01:02:XX:XX:XX'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device
option name 'eth1'
option macaddr '00:01:02:YY:YY:YY'

config interface 'wan'
option device 'eth1'
option proto 'dhcp'

config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
--------------------------------------------------------------------------
This example uses DSA with lanX interface names. A non-DSA device would use more classical ethX interface names.


LuCI update

LuCI has been updated to support the most recent network syntax (and migrate old config files if needed). In some cases migration will take 2 steps.

Support for configuring devices (config device UCI sections) was added.
It can be used for setting layer 2 options (like MTU and MAC address).
It also supports bridge devices (including VLAN tagging).


LuCI HTTPS

LuCI is now available over HTTPS in addition to HTTP in the default images.
After an upgrade from OpenWrt 19.07 to OpenWrt 21.02 unencrypted HTTP requests are redirected to HTTPS. On fresh OpenWrt 21.02 installations they are not edirected. Deactivate the redirect to HTTPS like this:
--------------------------------------------------------------------------
uci set uhttpd.main.redirect_https=0
uci commit uhttpd
service uhttpd reload
--------------------------------------------------------------------------


Software updates

* Linux kernel updated to version 5.4.119 (from 5.4.111 in v21.02.0-rc1)
* mac80211 updated to version 5.10.34-1 (from 5.10.16-1 in v21.02.0-rc1)
* mac80211 backport upstream fixes for the new FragAttacks vulnerabilities in 802.11
* mt76 updated to latest version
* dnsmasq updated to version 2.85 (from 2.84 in v21.02.0-rc1)
* busybox updated to version 1.33.1 (from 1.33.0 in v21.02.0-rc1)

Misc changes

* Linux kernel fix parsing fixed subpartitions
* Linux kernel Activate FORTIFY_SOURCE for MIPS kernel 5.4
* busybox add SRV support to nslookup_lede.c patch
* busybox disable PREFER_IPV4_ADDRESS
* openwrt-keyring only copy sign key for 21.02
* sdk, imagebuilder unset BINARY_FOLDER and DOWNLOAD_FOLDER in final archives
* uqmi fix network registration loop

Device support

* Lantiq DSL multiple backports for DSL statistics
* New devices MikroTik SXTsq 5 ac, MikroTik hAP ac2
* Device fixes for ALFA Network devices, Youku YK1, TP-Link AD7200, TP-Link EAP-225, TP-Link TL-WR810N v1, MikroTik RB922UAGS-5HPaCD


Known issues

* LuCI network migration tool doesn't migrate custom bridge MAC addresses. Custom device MAC has to be set again manually.


Full release notes and upgrade instructions are available at https://openwrt.org/releases/21.02/notes-21.02.0-rc2

In particular, make sure to read the regressions and known issues before upgrading: https://openwrt.org/releases/21.02/note ... own_issues

For a detailed list of all changes since 21.02.0-rc1, refer to https://openwrt.org/releases/21.02/chan ... 1.02.0-rc2

To download the 21.02.0-rc2 images, navigate to: https://downloads.openwrt.org/releases/21.02.0-rc2/

  Więcej na forum…  
Starsze wiadomości  
designed by digi-led.pl
góra
...Copyright © 2010-2017, Ekipa openrouter.info